Simscape™
Getting Started Guide

7

MATLAB&SIMULINK

R2020a ¢ } MathWorkse



X B

How to Contact MathWorks

Latest news: www .mathworks. com

Sales and services: www.mathworks.com/sales_and_services
User community: www .mathworks.com/matlabcentral
Technical support: www . mathworks.com/support/contact_us
Phone: 508-647-7000

The MathWorks, Inc.
1 Apple Hill Drive
Natick, MA 01760-2098

Simscape™ Getting Started Guide
© COPYRIGHT 2007-2020 by The MathWorks, Inc.

The software described in this document is furnished under a license agreement. The software may be used or copied
only under the terms of the license agreement. No part of this manual may be photocopied or reproduced in any form
without prior written consent from The MathWorks, Inc.

FEDERAL ACQUISITION: This provision applies to all acquisitions of the Program and Documentation by, for, or through
the federal government of the United States. By accepting delivery of the Program or Documentation, the government
hereby agrees that this software or documentation qualifies as commercial computer software or commercial computer
software documentation as such terms are used or defined in FAR 12.212, DFARS Part 227.72, and DFARS 252.227-7014.
Accordingly, the terms and conditions of this Agreement and only those rights specified in this Agreement, shall pertain
to and govern the use, modification, reproduction, release, performance, display, and disclosure of the Program and
Documentation by the federal government (or other entity acquiring for or through the federal government) and shall
supersede any conflicting contractual terms or conditions. If this License fails to meet the government's needs or is
inconsistent in any respect with federal procurement law, the government agrees to return the Program and
Documentation, unused, to The MathWorks, Inc.

Trademarks

MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See
www .mathworks . com/trademarks for a list of additional trademarks. Other product or brand names may be
trademarks or registered trademarks of their respective holders.

Patents

MathWorks products are protected by one or more U.S. patents. Please see www.mathworks.com/patents for
more information.


https://www.mathworks.com
https://www.mathworks.com/sales_and_services
https://www.mathworks.com/matlabcentral
https://www.mathworks.com/support/contact_us
https://www.mathworks.com/trademarks
https://www.mathworks.com/patents

Revision History

September 2007
March 2008
October 2008
March 2009
September 2009
March 2010
September 2010
April 2011
September 2011
March 2012
September 2012
March 2013
September 2013
March 2014
October 2014
March 2015
September 2015
October 2015
March 2016
September 2016
March 2017
September 2017
March 2018
September 2018
March 2019
September 2019
March 2020

Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only
Online only

New for Version 2.0 (Release 2007b)
Revised for Version 2.1 (Release 2008a)
Revised for Version 3.0 (Release 2008b)
Revised for Version 3.1 (Release 2009a)
Revised for Version 3.2 (Release 2009b)
Revised for Version 3.3 (Release 2010a)
Revised for Version 3.4 (Release 2010b)
Revised for Version 3.5 (Release 2011a)
Revised for Version 3.6 (Release 2011b)
Revised for Version 3.7 (Release 2012a)
Revised for Version 3.8 (Release 2012b)
Revised for Version 3.9 (Release 2013a)
Revised for Version 3.10 (Release 2013b)
Revised for Version 3.11 (Release 2014a)
Revised for Version 3.12 (Release 2014b)
Revised for Version 3.13 (Release 2015a)
Revised for Version 3.14 (Release 2015b)

Rereleased for Version 3.13.1 (Release 2015aSP1)

Revised for Version 4.0 (Release 2016a)
Revised for Version 4.1 (Release 2016b)
Revised for Version 4.2 (Release 2017a)
Revised for Version 4.3 (Release 2017b)
Revised for Version 4.4 (Release 2018a)
Revised for Version 4.5 (Release 2018b)
Revised for Version 4.6 (Release 2019a)
Revised for Version 4.7 (Release 2019b)
Revised for Version 4.8 (Release 2020a)






Contents

Product Fundamentals

1]

Creating a New Simscape Model ... ... ........................... 1-2
Domain Types and Recommended Blocks . ........................ 1-2
Data Logging Settings for New Model . ........................... 1-3

Evaluating Performance ofaDCMotor ............................ 1-5

Essential Steps for Constructing a Physical Model ................. 1-11
WOTKEIOW OVEIVIEW . . . oot e e e e 1-11
Step 1: Create New Model Usingssc new ...................c..... 1-12
Step 2: Assemble Physical Network ... ...................... ... 1-13
Step 3: Adjust Block Parameters and Variable Targets ............... 1-14
Step 4: Add Sources . ... .. 1-16
Step 5: Add Sensors . . ... 1-17
Step 6: Connect to Simulink with Interface Blocks ................. 1-18
Step 7: Simulate Model .. ..... ... ... .. . .. ... 1-22
Step 8: View Simulation Results . ........... ... ... ... ....... 1-23






Product Fundamentals

* “Creating a New Simscape Model” on page 1-2
» “Evaluating Performance of a DC Motor” on page 1-5
* “Essential Steps for Constructing a Physical Model” on page 1-11



1 Product Fundamentals

Creating a New Simscape Model

In this section...

“Domain Types and Recommended Blocks” on page 1-2
“Data Logging Settings for New Model” on page 1-3

Domain Types and Recommended Blocks

Simscape models require certain blocks to be present in the model configuration, such as a Solver
block, or domain-specific reference blocks. Other blocks, although not required, are highly likely to
be needed, such as Simulink-PS Converter and PS-Simulink Converter blocks. An easy way to start a
new Simscape model is by using the ssc_new function.

When you type ssc_new at the MATLAB® Command prompt, the software creates a new model
prepopulated with certain blocks.

untitled

[C] @] untitled
@) P Lo
El Simulink-P5 PE-Simulink
Converter Converter Scope
=
=

Salver
Configuration

Simscape Library Resources

1. Find components in the Simscape library.
For more information, see Physical Modeling - Blocks.

2. Connect the compenents to form a physical network.
For more information, see Essential Steps for Constructing a Physical Model.

3. Explore simulation results using sscexplore

v @ @

Ready 100% VariableStepAuto

By default, the model name is not specified, the model contains a Solver Configuration block, a
Simulink-PS Converter block, and a PS-Simulink Converter block connected to a Scope block. The
default solver is VariableStepAuto. The resources section at the bottom of the model window
provides links to the relevant block libraries and documentation topics.

You can use the ssc_new function arguments to specify the model name and add domain-specific
blocks. See the ssc_new reference page for details. For example, typing

ssc_new( 'pneumatic_actuator', 'gas')

creates the following model.
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Creating a New Simscape Model

preumatic_actuator

& |[*&| preumatic_actuator -
C} P r»—»@l
Simulink-FS P5-Simulink
E3 Converter Converter Scape
=
_ .
i L -1
Gas Properties (G)

Solver
Configuration

Reservair (5)

Simscape Foundation Gas Resources

1. Find more gas components in the Simscape Foundation Gas library.
For more information, see Gas Models - Blocks.
1] 2. Find components from other domains in the Simscape library.
[ 3. Connect the components to form a physical network.
For more information, see Essential Steps for Constructing a Physical Model.
» 4. Explore simulation results using sscexplore

Ready 100% VariableStepAuto

After using ssc_new, continue developing your model by copying the blocks, as needed, and adding
other blocks from the Simscape libraries.

For electrical models, you can also use the Creating A New Circuit example as a template for a new
model. This example creates a new electrical model and opens an Electrical Starter Palette, which
contains links to the most often used electrical components. Open the example by typing

ssCc_new elec in the MATLAB Command Window and use File > Save As to save it under the
desired model name. Then delete the unwanted components and add new ones from the Electrical
Starter Palette and from Simscape libraries.

Data Logging Settings for New Model

Using data logging is a best practice for Simscape models because it provides access to important
simulation and analysis tools. Therefore, the ssc_new function automatically turns on data logging
for the whole model. It uses the default workspace variable name simlog to store simulation data,
and limits the data to the last 10000 points to avoid slowing down simulation. At the same time, it
raises MaxDataPoints to 10000, so that Simulink® data logging history matches Simscape data
logging history.

When you create a new model using ssc_new, the model has the following data logging
configuration:

* Log simulation data — Al1.

* Log simulation statistics — Off.

* Record data in Simulation Data Inspector — Off.

* Open viewer after simulation — Off.

* Workspace variable name — simlog.

* Decimation — 1.

* Limit data points — On.
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* Data history (last N steps) — 10000.

For information on what these settings mean and how to change them, see “Data Logging Options”.

See Also
SSC_new

More About

. “Select Solver Using Auto Solver” (Simulink)
. “Making Optimal Solver Choices for Physical Simulation”
. “Data Logging Options”
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Evaluating Performance of a DC Motor

This example shows how to simulate systems that span electrical and mechanical domains. You learn
how to model physical components with Simscape blocks, connect them into a realistic model, use
Simulink blocks as well, and then simulate and modify a motor model.

The model is based on a Faulhaber Series 0615 DC-Micromotor. The model uses equivalent circuit
parameters for the 1.5V motor to verify manufacturer-quoted no-load speed, no-load current, and stall
torque. You can use the model to assess motor performance in a given application by adding the
requisite mechanical load model.

Explore the Model

1 To open the Permanent Magnet DC Motor example model, type ssc_dcmotor in the MATLAB
Command Window.

Load Torgue

v R R f‘l
\.-'ona[;g g%/m_ W - Step Input
v \__._,/ c |

fix)=0 b Motor
RPM

DC Motor

Main Model

The model contains a DC Motor subsystem with two electrical and two mechanical rotational
ports.

For improved readability of block diagrams, each Simscape domain uses a distinct default color
and line style for the connection lines. In this block diagram, for example, the electrical circuit is
indicated by the dark-blue color of the connection lines, while the connection lines between the
mechanical rotational ports are light-green. Physical signal lines are brown.

The electrical ports of the motor connect to the electrical circuit, which consists of an Electrical
Reference block, representing an electrical ground, and a 1.5 V DC voltage source.

On the mechanical side, a Mechanical Rotational Reference block represents a reference point
for the other elements.

The motor load is represented by the block named Load Torque, which is an Ideal Torque Source
block. On one side it is connected to a Mechanical Rotational Reference block and on the other
side to the motor shaft. The load torque is specified by the Step Input subsystem, connected
through a physical signal to the control port S of the Load Torque block.

L

{1 <a

5

The Step Input subsystem contains a regular Simulink Step source, which provides the control
signal. A Simulink-PS Converter block converts the control signal into a physical signal and
applies it to the control port of the Load Torque block through the Connection Port block S.
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The diagram also contains a Solver Configuration block, which is required in any Simscape
model. It contains parameters relevant to numerical algorithms for Simscape simulations.

Double-click the DC Motor subsystem to open it.

Inertia

W+ R
' ™
Rotational o
Electromechanical  (()--- Friction

Converter o

<32

cC

DC Motor Subsystem

The motor consists of an electrical circuit and a mechanical rotational circuit, connected by the
Rotational Electromechanical Converter block. The electrical circuit consists of a Resistor block
and an Inductor block. It contains two electrical ports, corresponding to the V+ and V- electric
terminals of the motor. The mechanical circuit contains a Rotational Friction block, an Inertia
block, and two mechanical rotational ports, C and R, corresponding to the motor case and rotor,
respectively. Notice how the C and R ports of the Rotational Friction block and the Rotational
Electromechanical Converter block are connected to the C and R ports of the motor, to preserve
the correct direction of variables in the physical network.

Run the Model

1

Double-click the Motor RPM scope to open it. During simulation, this window displays the shaft
speed as a function of time.

() N . -
Click 2 to start the simulation. The Simscape solver evaluates the model, calculates the initial
conditions, and runs the simulation. This process might take a few seconds. The message in the
bottom-left corner of the model window provides the status.

Examine the simulation results in the Motor RPM scope window.



Evaluating Performance of a DC Motor

4 Mator RPM — d x
File Tools  View  Simulation  Help k
- Q0P ® = a-|C- 44

10

Ready T=0.200

For the first 0.1 seconds, the motor has no external load, and the speed builds up to the no-load
value. Then at 0.1 seconds, the stall torque is applied as a load to the motor shaft. Zooming in on
the Motor RPM scope shows that the model matches the manufacturer parameters for no-load
speed and stall torque.

The example model also shows how you can use MATLAB code to analyze the simulation results.
To plot the current and load torque, click the Plot hyperlink in the model annotation. The
current shown in the figure matches the manufacturer parameters for no-load current.
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4\ Figure 1: ssc_dcmotor -

File Edit View Insert Tools Desktop Window Help

Odde 2 RXKODEA- S| 0E

Motor Current
I:Id' T T T T T T T

=
L

Current (&)
=
M2

0.1 .
D i i i i i i i i i
0 002 004 006 008 0.1 012 014 046 018 0.2
x10* Load Torque
D -
E
At .
k]
=
=
S2f :
_3 i i i i i i i i i
0 002 004 006 008 0.1 012 014 046 018 0.2
Time (s)

Change the Supply Voltage

Reduce the supply voltage to 1.25 volts (to simulate the battery running down) and vary the load

torque to find the maximum torque at this reduced voltage.
1 Double-click the DC Voltage Source block. Set Constant voltage to 1.25 V.

Block Parameters: DC Voltage ™
DC Voltage Source
The ideal voltage source maintains a constant voltage across its output terminals, independent of the current

flowing through the source. The output voltage is defined by the Constant voltage parameter, and can be any
real value.

Source code
Settings

Parameters

Constant voltage: 1.25 ‘ |V w

Cancel Help Apply

2 Run the simulation. Note the effect of reduced voltage on the no-load speed.
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4 Mator RPM — d x
File Tools  View  Simulation  Help k
- Q0P ® = a-|C- 44

10

Ready T=0.200

Try varying the load torque to find the maximum torque at this reduced voltage. Open the Step
Input subsystem and double-click the Step source block. Enter different final values for the input

signal and rerun the simulation.

The next illustration shows the simulation results for Final value set to -0.2e-3, which
corresponds to (1.25/1.5)*0.24mNm, as the magnitude of the torque-speed curve is

proportional to voltage for a DC motor.

4| Motor RPM - O *

File Tools View Simulation Help R

B-BOP® = a- - 4FH-

Ready Sample bazed T=0.200

Change the Motor Load

Replace the torque source with a simple mechanical load, for example, a fan, for which the torque is
defined by alpha*speed”2, where alphais -1e-10 Nm/(rad/s)" 2.
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N
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Delete the Step Input subsystem from the model.

In the Simscape block library, open Foundation Library > Mechanical > Mechanical
Sensors.

Drag the Ideal Rotational Motion Sensor block to the model window.
Open Foundation Library > Physical Signals > Functions.
Drag the PS Product block and the PS Gain block to the model window.

Connect the blocks as shown in the following illustration. To rotate a block, select it and press
Ctrl+R.

Load Torgue
= _o 4 N

=4 [ \@}_ |

A V—T—D
ok —

f(x)=0

1 DC Motor l—i—l

Motor
RPM

Double-click the PS Gain block to open its dialog box. In the first edit box next to the Gain
parameter, enter the value of -1e-10. In the second combo box, with the unit drop-down list,
type the unit expression N*m/ (rad/s)”2 and click OK.

Run the simulation and assess motor performance with the new load.

4| Motor RPM - O *

File Tools View Simulation Help R

B-BOP® = a- - 4FH-

Ready T=0.200
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Essential Steps for Constructing a Physical Model

In this section...

“Workflow Overview” on page 1-11
“Step 1:
“Step 2:
“Step 3:
“Step 4:
“Step 5:
“Step 6:
“Step 7:
“Step 8:

Assemble Physical Network” on page 1-13

Add Sources” on page 1-16

Add Sensors” on page 1-17

Connect to Simulink with Interface Blocks
Simulate Model” on page 1-22

View Simulation Results” on page 1-23

Create New Model Using ssc_new” on page 1-12

Adjust Block Parameters and Variable Targets” on page 1-14

” on page 1-18

Workflow Overview

The table lists the essential major steps for building and simulating a physical model, along with
related documentation topics that provide background information on each step. Detailed step

descriptions follow.

Key Step

Related Topics

“Step 1: Create New Model Using ssc new” on
page 1-12

“Setting Up Solvers for Physical Models”

Solver Configuration

“Step 2: Assemble Physical Network” on page 1-
13

“Basic Principles of Modeling Physical Networks”
“Essential Physical Modeling Techniques”

“Modeling Best Practices”

“Step 3: Adjust Block Parameters and Variable
Targets” on page 1-14

“Block-Level Variable Initialization”

“Variable Viewer”

“Step 4: Add Sources” on page 1-16

“Basic Principles of Modeling Physical Networks”

“Connecting Simscape Diagrams to Simulink
Sources and Scopes”

“Step 5: Add Sensors” on page 1-17

“Basic Principles of Modeling Physical Networks”

“Connecting Simscape Diagrams to Simulink
Sources and Scopes”

“Step 6: Connect to Simulink with Interface
Blocks” on page 1-18

“Connecting Simscape Diagrams to Simulink
Sources and Scopes”

“Step 7: Simulate Model” on page 1-22

“Important Concepts and Choices in Physical
Simulation”

“Troubleshooting Simulation Errors”
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Key Step

Related Topics

“Step 8: View Simulation Results” on page 1-23

“About Simulation Data Logging”

“About the Simscape Results Explorer”

The graphic illustrates the key workflow steps as applied to the Mass-Spring-Damper with Controller
example model. Step descriptions below include detailed instructions on how to create this model.

— O
SIMULATION Block Parameters: Mass *
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FILE | LIERARY | FREPARE | SIMULATE 1 Override Variable Priority Beginning Value
| Velocity ~ |High = |10
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| ® ssc_mass_spring_damper_contrnl / D Force None ~ I:
v
| & / < >
| B3 3 OK Cancel Help Apply
=
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Ready

Step 1: Create New Model Using ssc_new

Using ssc_new is the best way to start building Simscape models. It helps to ensure that you use
recommended default settings for your model. When you use ssc_new, it automatically:

* Creates a new Simscape model, with required and commonly used blocks already on the model

canvas

* Selects recommended solver and tolerance settings

* Enables data logging for the whole model

Detailed Instructions

In the MATLAB Command Window, type:
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SsC_new
untitled
® @] untitled -
=3
(]
Simscape Library Resources

=] 1. Find components in the Simscape library.

For more information, see Physical Modeling - Blocks.
|I_—| 2. Connect the compenents to form a physical network.

For more information, see Essential Steps for Constructing a Physical Model.
» 3. Explore simulation results using sscexplore
Ready 100% VariableStepAuto

The new untitled model, with the default solver set to VariableStepAuto, contains a Solver
Configuration block, a Simulink-PS Converter block, and a PS-Simulink Converter block connected to

a Scope block.
The resources section at the bottom of the model window provides links to the relevant block libraries

and documentation topics.

Step 2: Assemble Physical Network

To model your system, you add blocks from the Simscape libraries to a model, and then connect them
into a physical network. The lines connecting the blocks in the schematic you create represent the
physical connections that exist between the components in a real system that you are modeling. In
other words, Simscape diagrams mimic the physical system layout.

I o
_p Translational Tranzslational
Damper T > Spring
Mechanical
’ Translational
Reference
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When constructing your network, it is important to include domain-specific reference blocks, such as
Electrical Reference, Mechanical Translational Reference, and so on. Depending on domain, these
blocks represent connection to ground, frame, or atmosphere. For more information, see “Grounding
Rules”.

Detailed Instructions

Open the Simscape > Foundation Library > Mechanical > Translational Elements library.

Drag the Mass, Translational Spring, Translational Damper, and Mechanical Translational
Reference blocks into the model window.

3 Connect the Translational Spring, Translational Damper, and Mass blocks to the Mechanical
Translational Reference block as shown in the next illustration. To rotate a block, select it and
press Ctrl+R.

To adjust visual presentation of the model, shorten the names of the Spring and Damper blocks,
as shown. To have the name of the Mass block appear along with Spring and Damper, right-click
the Mass block and, from the context menu, select Format > Show Block Name > On.

f(x)=0

Damper

Step 3: Adjust Block Parameters and Variable Targets

Simscape blocks represent generic components that have default initial values for block parameters
and variables. You can adjust these values to suit your application or match the manufacturer data
sheet.

Detailed Instructions

In this model, you will adjust parameters that control the mass, the spring stiffness, and the damping
coefficient. You will also specify the initial velocity of the mass by adjusting the respective variable
target.

1 Double-click the Spring block. Set its Spring rate to 400 N/m.
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Block Parameters: 5pring »

Translational Spring

The block represents an ideal mechanical linear spring.

Connections R and C are mechanical translational conserving ports. The block positive direction is from port R to
port C. This means that the force is positive if it acts in the direction from R to C.

Source code
Settings

Parameters  Variables

Spring rate: 400 | | N/m ~

Cancel Help Apply
2 Double-click the Damper block. Set its Damping coefficient to 100 N/ (m/s).

Block Parameters: Damper %

Translational Damper

The block represents an ideal mechanical translational viscous damper.

Connections R and C are mechanical translational conserving ports, with R representing the damper rod, while C
is associated with the damper case. The block positive direction is from port R to port C.

Source code
Settings

Parameters  Variables

Damping coefficient: 100 | | N/(m/s) ~

Cancel Help Apply
3 Double-click the Mass block. Set its Mass to 3.6 Kkg.

Block Parameters: Mass »

Mass

The block represents an ideal mechanical translational mass.

The block has one mechanical translational conserving port. The block positive direction is from its port to the
reference point. This means that the inertia force is positive if mass is accelerated in positive direction.

Source code
Settings

Parameters  Variables

Mass: 3.6 | | kg ~

Cancel Help Apply

4 To specify the desired initial value for mass velocity, click the Variables tab. The Velocity
variable already has its Priority specified as High. In the Beginning Value field, type 10, then
click Apply.
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Block Parameters: Mass »
Mass

The block represents an ideal mechanical translational mass.

The block has one mechanical translational conserving port. The block positive direction is from its port to the
reference point. This means that the inertia force is positive if mass is accelerated in positive direction.

Source code
Settings

Parameters ~ Variables

Override Variable Priority Beginning Value Unit

Velocity High = 10 m/s ~

O Force None <~ 0 N v o
< >

Cancel Help Apply

Note that the Override check box next to the Velocity variable is now selected, which means
that you have overridden the default variable initialization value. This variable has high priority,
therefore, the solver will try to exactly satisfy this beginning value when it computes the initial
conditions to determine the simulation starting point.

Step 4: Add Sources

You can drive Simscape models using input signals. This technique allows you to represent physical
effects, such as forces, voltages, or pressures, that act on your system. You can also specify other
quantities that flow through your system, such as current, mass flow rate, and heat flux. You add
signal input connections to your physical network by using Simscape source blocks.

Detailed Instructions

To add the representation of the force acting on the mass, use the Ideal Force Source block.

Open the Simscape > Foundation Library > Mechanical > Mechanical Sources library.
Add the Ideal Force Source block to your diagram. Shorten the block name, as shown.

To reflect the correct direction of the force shown in the original schematic, flip the block
orientation. With the Force Source block selected, on the Format tab of the Simulink Toolstrip,
under Arrange, click Flip up-down.

Copy the Mechanical Translational Reference block by right-clicking it and dragging to a new
location. Then flip the orientation of the new block using the same technique as with the Force
Source block.

Connect port C of the Force Source block to this second Mechanical Translational Reference
block and port R to the Mass block, as shown below.

The input signal for the force profile will be supplied through port S, after you connect the
physical network to a Simulink source (see “Step 6: Connect to Simulink with Interface Blocks”
on page 1-18). A positive signal at port S will specify a force that acts from port C to port R.



Essential Steps for Constructing a Physical Mode

f(x)=0

Step 5: Add Sensors

You can measure quantities from your physical network and use them in other locations in your
model. Some common uses of those quantities include feedback for a control algorithm, modeling
physical components whose behavior depends on other physical quantities (such as temperature-
dependent resistor), or simply viewing the results during simulation.

You measure quantities using sensor blocks, connected in series or in parallel depending on the
measured value. To measure a quantity defined by a Through variable (such as current, flow rate,
force), connect the sensor in series. To measure a quantity defined by an Across variable (such as
voltage, pressure, velocity), connect the sensor in parallel. For more information on Through and
Across variables, see “Variable Types”.

Detailed Instructions

To measure spring deformation, connect an Ideal Translational Motion Sensor block in parallel with
the spring.

Open the Simscape > Foundation Library > Mechanical > Mechanical Sensors library.

Add the Ideal Translational Motion Sensor block to your diagram.

To rotate the block, select it and press Ctrl+R.

A W N R

Connect the block as shown in the next illustration. Shorten the block name, as shown.
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Step 6: Connect to Simulink with Interface Blocks

Equations in a Simscape network are solved simultaneously, while Simulink blocks are evaluated
sequentially. Interface blocks, such as Simulink-PS Converter and PS-Simulink Converter, handle the
boundary between these two modeling conventions. You need interface blocks when Simulink signals
specify quantities in a Simscape network, or when passing Simscape quantities to Simulink for
control design or other purposes. Every time you connect a Simulink block to a Simscape physical
network, you have to use an appropriate converter block.

Detailed Instructions

You are now going to connect your physical network to a controller built out of regular Simulink
blocks. First, prepare the physical network to be connected to Simulink signals:

1 Delete the Scope block.

While you can use scopes to view simulation results, they add clutter to the block diagram. A
more efficient way to view and analyze simulation results is to use the Simscape Results Explorer,
as described in “Step 8: View Simulation Results” on page 1-23.

2  Connect the physical signal output port of the Simulink-PS Converter block to port S of the Force
Source block.

3  Connect the output port P of the Motion Sensor block to the physical signal input port of the PS-
Simulink Converter block.

4 Connect the Solver Configuration block to the circuit and hide the converter block names. Your
diagram now looks like this.
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3.

Force
Source
Mass
A ‘ {

Mot el o
otion § .
Sensor X . Damper Spring

Then, build and connect the controller:

1  Open the Simulink > Sources library and drag the Pulse Generator block into the model. Change
the block name to Position Command. Set the block parameters as shown.

Block Parameters: Position Command =
Pulse Generator

Output pulses:

if (t >= PhaseDelay) && Pulse is on
Y(t) = Amplitude

else
Y(t) =0

end

Pulse type determines the computational technique used.

Time-based is recommended for use with a variable step solver, while
Sample-based is recommended for use with a fixed step solver or within a
discrete portion of a model using a variable step solver.

Parameters

Pulse type: |Time based -
Time (t): | Use simulation time -

Amplitude:
[os [

Period (secs):
s B

Pulse Width (% of period):
[s0 [

Phase delay (secs):
E B

Interpret vector parameters as 1-D

\_)' Cancel Help Apply

2 Open the Simulink > Math Operations library and drag the Sum block into the model. In the List
of signs, replace the second plus sign with a minus sign, as shown.
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Block Parameters: Sum ®
Sum

Add or subtract inputs. Specify one of the following:

a) character vector containing + or - for each input port, | for spacer
between ports (e.g. ++|-|++)

b) scalar, >= 1, specifies the number of input ports to be summed.
When there is only one input port, add or subtract elements over all
dimensions or one specified dimension

Main  Signal Attributes
Icon shape: |round

List of signs:

[+

5_)- Cancel Help Apply

3 Open the Simulink > Continuous library and drag the PID Controller block into the model. Set
the Proportional (P), Integral (I), and Derivative (D) parameter values as shown.
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Block Parameters: PID Controller %
PID 1dof (mask) (link)

This block implements continuous- and discrete-time PID control algerithms and includes advanced features such as anti-
windup, external reset, and signal tracking. You can tune the PID gains automatically using the "Tune...' button (requires
Simulink Control Design).

Controller: | PID | Form: Parallel -
Time domain: Discrete-time settings

@ Continuous-time
Sample time (-1 for inherited): -1
O Discrete-time

¥ Compensator formula

pirtip N -
5 14N
5

Main  Initialization =~ Output Saturation  Data Types  State Attributes
Centroller parameters

Source: | internal -

Proporticnal (P): |}'00 | B

Integral (1): 4000 [

Derivative (D): [15 [

Use filtered derivative

Filter coefficient (N): |100 E

Automated tuning

Select tuning method: | Transfer Function Based (PID Tuner App) - Tune...

Enable zero-crossing detection

Cancel Help Apply

Connect the blocks as shown in the following diagram.

Paosition
Command Force L
Source |

Mass

iy

Motion

Sensor Spring
0

The control Simulink signal goes to the input port of the Simulink-PS Converter block, where it is
converted into a physical signal driving the force profile of the Ideal Force Source block.

1-21



1 Product Fundamentals

1-22

The output port P of the Ideal Translational Motion Sensor block, which measures the spring
deformation, connects to the PS-Simulink Converter block. This block converts the physical
signal into a feedback Simulink signal for the controller.

To compare the input and feedback signals, connect them to a signal viewer:
1 Right-click the Simulink signal that goes from the Pulse Generator block to the Sum block. From

the context menu, select Create & Connect Viewer > Simulink > Scope.

2 Then, right-click the Simulink signal that goes from the PS-Simulink Converter block to the Sum
block. From the context menu, select Connect To Viewer > Scope.

Step 7: Simulate Model

You run simulations by clicking the Run button & in the Simulink Toolstrip (at the top of the model
window) or in a Scope Viewer toolbar. The Simscape solver evaluates the model, calculates the initial
conditions, and runs the simulation. For a detailed description of this process, see “How Simscape
Simulation Works”. The message in the bottom-left corner of the model window provides the status
update.

Detailed Instructions

To run the simulation, click & in the Simulink Toolstrip.
The Scope Viewer displays overlaid plots of the input and feedback signals.

4. Viewer: Scope - O X
File Teools View Simulation Help N
9 4OP® T - |H-|FA-

M nand, I

Ready Sample based |T=10.000
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Step 8: View Simulation Results

The Simscape Results Explorer lets you view and analyze simulation data by using the data logging
functionality. For example, you can compare two simulation runs to analyze how changing the mass
affects the spring deformation.

Detailed Instructions

Right-click the Spring block.
From the context menu, select Simscape > View simulation data > simlog.

Note simlog is the default name of the log variable. If you change the variable name using the
Workspace variable name model configuration parameter, the context menu lists that name as
the log variable associated with the block.

The Simscape Results Explorer window opens, with the node corresponding to the Spring block
highlighted in the left pane. The right pane displays the simulation data plots for the three
variables associated with the block.

4. Simscape Results Explorer: ssc_mass_spring_damper_control - O X
File Edit View Insert Tools Desktop Window Help N
@ |20 kE
B ] @
f
i ssc_mass_spring_damper_control 200 F T T ——— T T ———
Damper i II /
[ Force Source 150 i | | b
H |
MTR1 L | II II |
100 |
MTR2 = [ | |I |
Mass 50 ‘II | | il 4
([ Motion Sensor I|I |I I'.\ |
- ; oH ——— NS — 4
SP"“g A L L L L L L L L L
0 1 2 3 4 5 6 7 8 9 10
Time (s)
v
10 T T T T T T T T T
5k i
E?. I
E \ \
~ g ]I_ — , : /_ o
v /
-5 1 1 1 1 1 1 1 1 1
0 1 2 3 4 5 6 7 8 9 10
Time (s)
X
0.6 T T T T T T T T T
— \ Y
04 II ! g
|
1 |
E 02f I.' \ f d
- \ \ |
Statistics for selected node: 0 _I'.I . f N / i
Description: Spring e
MNumber of time steps: 306 02 | | | | | I I I I
MNumber of logged variables: 5 "o 1 2 3 4 5 6 7 8 g 10
MNumber of logged zero crossing signals: 0 Time (s)
Source: Spring

3 Expand the Spring node and select node x. The right pane displays the spring deformation data
plotted over time.
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|4\ Simscape Results Explorer: ssc_mass_spring_damper_control

File Edit View Insert Tools Desktop Window Help

NI

NEGlE
E_i ssc_mass_spring_damper_control 0.6 T T T T T T T T T
Ei Damper
Ei Force Source
8 MTR1 §
8 MTR2 05 - [‘\,ﬁ—| S~
@6 Mass || ‘ I|'
Ei Mation Sensor |
E|Ei Spring
B C

| ‘ |
04 | | J

03 ‘ ‘ |

4m

0.2 I ‘ | ‘
0.1 -I

0 -

| s
Statistics for selected node: ||
Description: Deformation \

Unit conversion: absolute | | | | | | | | |
MNumber of time steps: 306

MNumber of logged variables: 1 L U £ g o 2 ® f £ 3 i
MNumber of logged zero crossing signals: 0

Source: Spring

4 Double-click the Mass block. Set its Mass to 7.2 kag.
5 Rerun the simulation.

To reload the logged data, click the button located in the toolbar of Simscape Results
Explorer window. In the pop-up window displaying the variable name, click OK.
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|4\ Simscape Results Explorer: ssc_mass_spring_damper_control

File Edit View Insert Tools Desktop Window Help

NI
FEAEIE

L:LJ ssc_mass_spring_damper_control
LJJ Damper
LJJ Force Source

LJJ Mass
LJJ Motion Sensor
BL]J Spring

Statistics for selected node:

Description: Deformation

Unit conversion: absolute

MNumber of time steps: 317

MNumber of logged variables: 1

MNumber of logged zero crossing signals: 0

Source: Spring

4m

0.6

0.5

0.4

|
D.3u|

0.2

0.1

10

Notes

* To have the data reload automatically after each simulation run, in the Configuration
Parameters dialog box, in the Simscape pane, select the Open viewer after simulation

check box.

* To explore the simulation results side by side, in two separate Simscape Results Explorer

. = . . . .
windows, use the button after the first simulation run. For more information, see “About
the Simscape Results Explorer”.
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